You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by BirdieBob (Aug 4th 2011, 7:01pm)

1 150

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 150

by hi.todd

(Jun 19th 2009, 10:23pm)

by tabong (Jun 18th 2006, 5:10pm)

1 150

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 151

by GatorGuy

(Apr 23rd 2012, 8:47am)

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 152

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 152

by mrfixit

(Oct 16th 2011, 2:26am)

by evergreenz (Sep 3rd 2011, 2:33am)

2 152

by evergreenz

(Sep 3rd 2011, 12:08pm)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 155

No reply

by schlaiss (Jul 1st 2010, 9:25pm)

1 155

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by gerald (May 31st 2006, 5:44am)

2 155

by jmduke7

(Aug 17th 2006, 3:03pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)