You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by fragnus (Jul 25th 2010, 9:45pm)

3 974

by Wet_Boots

(Jul 27th 2010, 8:25pm)

by krantzr (Apr 30th 2011, 8:26am)

3 969

by mrfixit

(May 1st 2011, 11:34am)

by svsprinklers (May 19th 2010, 9:29pm)

2 953

by PhoenixDen

(Jun 24th 2010, 11:27am)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 953

by jmduke7

(Aug 17th 2006, 3:00pm)

by Gansmanms (Nov 7th 2012, 9:10pm)

7 927

by marian

(Sep 2nd 2013, 5:37pm)

by wrx884 (Apr 22nd 2011, 12:57am)

5 899

by Wet_Boots

(Apr 25th 2011, 9:37am)

by WHomeowner (Jul 24th 2011, 2:16pm)

10 893

by PennyInHeels

(Jun 25th 2013, 3:52pm)

by namodnom (Oct 25th 2005, 2:56pm)

9 877

by SprinklerGuy

(Mar 24th 2006, 1:56am)

by jrb (Jul 5th 2011, 7:11pm)

2 871

by hi.todd

(Jul 12th 2011, 6:46pm)

by lawnnovice (Jul 5th 2010, 3:03pm)

3 853

by Wet_Boots

(Jul 6th 2010, 7:00pm)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)