You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by sdguy (Mar 10th 2013, 3:15pm)

3 387

by Wet_Boots

(Jul 31st 2013, 10:41am)

by bobspitler (Jun 6th 2011, 7:10am)

1 285

by Mitchgo

(Jun 6th 2011, 9:34pm)

by lou40 (Nov 9th 2011, 4:15pm)

3 560

by Wet_Boots

(Nov 13th 2011, 8:15am)

by BRL (Jun 13th 2007, 2:03pm)

0 1,510

No reply

by carolinagirl (Aug 29th 2014, 5:00pm)

3 34

by Central Irrigation

(Aug 30th 2014, 7:13am)

by JT (Mar 9th 2014, 8:08pm)

1 152

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 1,855

by Wet_Boots

(Jun 20th 2012, 10:13am)

by nightshark (Sep 9th 2013, 3:11pm)

3 435

by mrfixit

(Sep 9th 2013, 6:05pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 507

No reply

by PSpatches (Apr 28th 2009, 10:31am)

1 235

by Candance

(May 9th 2009, 9:13pm)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)