You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by badsprinklers (Oct 10th 2007, 4:55pm)

12 2,387

by Wet_Boots

(Apr 27th 2008, 11:09am)

by avu3 (Jul 3rd 2005, 2:36pm)

4 359

by avu3

(Jul 4th 2005, 7:20pm)

by hettiep (May 27th 2005, 5:02am)

2 361

by Jazzer K

(Sep 2nd 2005, 6:22pm)

by osha (Aug 16th 2002, 4:34pm)

1 226

by Rays Sprinklers

(May 17th 2003, 2:53pm)

by handan (Nov 30th 2011, 11:30pm)

2 318

by handan

(Dec 2nd 2011, 4:56am)

by donlo (Apr 18th 2006, 3:20am)

0 142

No reply

by melprint (Jul 11th 2009, 9:06am)

1 256

by mrfixit

(Jul 11th 2009, 11:59am)

by Sue (Aug 11th 2005, 10:47am)

4 297

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 276

by Wet_Boots

(Sep 15th 2007, 12:31am)

by jackevln (Aug 20th 2006, 6:33am)

4 358

by mrfixit

(Aug 21st 2006, 5:12pm)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)