You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ksrmc (Aug 1st 2012, 3:27pm)

6 588

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Rsnic (Jun 17th 2012, 2:10pm)

6 2,097

by Wet_Boots

(Jun 20th 2012, 10:13am)

by alabama8100 (Jun 8th 2012, 1:35pm)

6 1,701

by GatorGuy

(Jun 11th 2012, 8:38am)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 486

by CRI IRR

(Sep 13th 2011, 6:34am)

by denm31 (Apr 4th 2011, 3:11pm)

6 562

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by Buff (Jun 6th 2008, 8:25am)

6 3,294

by mrfixit

(Jun 6th 2008, 1:59pm)

by julieblades (Jan 7th 2006, 6:27am)

6 274

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by Kevin Dearden (Jun 14th 2003, 4:15am)

6 518

by Rays Sprinklers

(Jul 2nd 2003, 8:52am)

by Stanman (Oct 28th 2014, 10:11pm)

5 174

by Wet_Boots

(Oct 30th 2014, 5:08am)

by abcoker (May 9th 2014, 2:43pm)

5 238

by Wet_Boots

(May 23rd 2014, 7:04am)

Show

Statistics:

460 Threads - 1,705 Posts (average 0.37 Posts per Day)