You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by alabama8100 (Jun 8th 2012, 1:35pm)

6 1,515

by GatorGuy

(Jun 11th 2012, 8:38am)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 381

by CRI IRR

(Sep 13th 2011, 6:34am)

by denm31 (Apr 4th 2011, 3:11pm)

6 464

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by Buff (Jun 6th 2008, 8:25am)

6 3,031

by mrfixit

(Jun 6th 2008, 1:59pm)

by julieblades (Jan 7th 2006, 6:27am)

6 176

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by Kevin Dearden (Jun 14th 2003, 4:15am)

6 388

by Rays Sprinklers

(Jul 2nd 2003, 8:52am)

by abcoker (May 9th 2014, 2:43pm)

5 144

by Wet_Boots

(May 23rd 2014, 7:04am)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 169

by PerryNZ

(Mar 14th 2014, 12:16am)

by beachdoc (May 19th 2012, 1:37pm)

5 929

by pavelow

(Oct 30th 2013, 9:51pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 419

by electrifiedmale

(Jun 30th 2013, 7:14pm)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)