You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by GraemeDunkley (May 4th 2013, 10:50pm)

5 877

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by Trabecca (Mar 13th 2013, 6:22pm)

7 1,056

by Trabecca

(Mar 18th 2013, 8:23am)

by ksrmc (Aug 1st 2012, 3:27pm)

6 987

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by whitty (Apr 20th 2012, 8:09am)

10 986

by GatorGuy

(Apr 23rd 2012, 8:45am)

by brobinson (Jun 12th 2010, 7:44am)

8 2,613

by Wet_Boots

(Mar 31st 2012, 4:43pm)

by bherholz (May 16th 2011, 12:06pm)

5 1,516

by mrfixit

(Jun 7th 2011, 5:46pm)

by rbuchas (May 27th 2011, 2:22pm)

8 2,386

by hi.todd

(Jun 3rd 2011, 4:52pm)

by stellar495 (Mar 17th 2011, 8:57pm)

3 2,137

by hi.todd

(Mar 20th 2011, 11:03am)

by t_shea (Sep 18th 2010, 10:46am)

5 3,213

by Wet_Boots

(Sep 20th 2010, 1:01pm)

by Dennis (Oct 15th 2007, 7:30am)

1 831

by edwildesr

(Nov 5th 2007, 7:53am)

Show

Statistics:

486 Threads - 1,840 Posts (average 0.36 Posts per Day)