You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by CRASH (Aug 6th 2015, 6:02pm)

3 211

by Wet boots

(Aug 7th 2015, 3:30pm)

by trs (Aug 4th 2015, 7:38pm)

2 918

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by Evergreen Sprinkler (Aug 4th 2015, 5:43pm)

0 294

No reply

by Jamie (Jul 29th 2015, 6:17pm)

1 193

by mrfixit

(Jul 29th 2015, 11:48pm)

by Sebastian2015 (Jul 28th 2015, 9:27am)

1 186

by Wet_Boots

(Jul 28th 2015, 11:15am)

by bjlarson (Jul 28th 2015, 9:20am)

1 100

by Wet_Boots

(Jul 28th 2015, 10:04am)

by OldBob (Jul 23rd 2015, 7:37am)

1 140

by OldBob

(Jul 23rd 2015, 8:13pm)

by Behan (Jul 17th 2015, 1:38pm)

1 146

by mrfixit

(Jul 17th 2015, 6:45pm)

by LX2 (Jul 16th 2015, 3:14pm)

2 197

by LX2

(Jul 17th 2015, 8:27am)

by Reg1987 (Jul 12th 2015, 7:43pm)

3 155

by Wet_Boots

(Jul 14th 2015, 6:12pm)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)