You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by BessMan94 (Jun 24th 2013, 8:45pm)

3 319

by mrfixit

(Jun 25th 2013, 8:32pm)

by WHomeowner (Jul 24th 2011, 2:16pm)

10 1,427

by PennyInHeels

(Jun 25th 2013, 3:52pm)

by 7907 (May 3rd 2013, 12:55am)

2 263

by PennyInHeels

(Jun 25th 2013, 9:49am)

by tico (Jun 15th 2013, 8:58pm)

0 364

No reply

by RonBLaGrone (Jun 4th 2013, 11:05am)

2 404

by Ronblagrone

(Jun 12th 2013, 10:23pm)

by DBLTRGR (Jun 9th 2013, 7:14pm)

1 219

by Wet_Boots

(Jun 9th 2013, 8:14pm)

by ruchuck (May 29th 2013, 8:54am)

7 500

by mrfixit

(Jun 2nd 2013, 12:03am)

by gobris (May 14th 2013, 9:45am)

3 424

by Wet_Boots

(May 16th 2013, 8:30am)

by rickthedrummer101 (May 11th 2013, 2:26pm)

1 264

by Wet_Boots

(May 11th 2013, 5:08pm)

by Rmiclette (May 5th 2013, 6:49am)

2 284

by Scott76

(May 5th 2013, 11:41am)

Show

Statistics:

436 Threads - 1,654 Posts (average 0.36 Posts per Day)