You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by MAG128 (Jun 24th 2015, 5:32pm)

3 264

by Wet_Boots

(Jun 26th 2015, 6:20am)

by jstanley (Aug 30th 2005, 5:37pm)

1 263

by SprinklerGuy

(Sep 6th 2005, 7:09am)

by fouracreDon (Mar 17th 2015, 8:09am)

2 262

by carlanw

(Apr 27th 2015, 10:52pm)

by Fisher (Aug 7th 2010, 5:43pm)

0 261

No reply

by stephen (May 2nd 2010, 12:11pm)

0 261

No reply

by LT87 (May 21st 2014, 11:33am)

3 259

by hi.todd

(May 27th 2014, 1:03pm)

by hlsrtony (May 26th 2015, 2:28pm)

3 255

by mrfixit

(May 27th 2015, 3:10pm)

by 68watford (Apr 30th 2006, 9:14am)

0 255

No reply

by Texas Tarheel (Jun 19th 2014, 8:33pm)

8 252

by irrigirl

(Jun 24th 2014, 12:26pm)

by mellow (May 31st 2015, 7:15pm)

4 251

by mrfixit

(Jun 2nd 2015, 4:08pm)

Show

Statistics:

486 Threads - 1,840 Posts (average 0.36 Posts per Day)