You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by LT87 (May 21st 2014, 11:33am)

3 176

by hi.todd

(May 27th 2014, 1:03pm)

by ash13 (Jun 1st 2014, 10:06am)

4 241

by Central Irrigation

(Jun 1st 2014, 6:17pm)

by WS-1 (May 9th 2010, 4:29pm)

28 9,471

by Romeo

(Jun 10th 2014, 3:57am)

by Texas Tarheel (Jun 19th 2014, 8:33pm)

8 130

by irrigirl

(Jun 24th 2014, 12:26pm)

by mjtalmadge (Sep 11th 2011, 2:30pm)

4 2,618

by Jlinfield

(Jul 4th 2014, 11:42am)

by 95mmrenegade (Jul 20th 2014, 10:30am)

4 127

by Central Irrigation

(Jul 20th 2014, 2:43pm)

by Benmt (Jul 24th 2014, 11:01pm)

2 153

by Benmt

(Jul 25th 2014, 1:46pm)

by Benmt (Jul 25th 2014, 8:34pm)

1 145

by Wet_Boots

(Jul 26th 2014, 6:30am)

by eddieruko (Jul 29th 2014, 4:52pm)

2 205

by eddieruko

(Jul 30th 2014, 12:31pm)

by rchead755 (Aug 23rd 2014, 11:36am)

2 152

by irrigirl

(Aug 25th 2014, 4:59pm)

Show

Statistics:

437 Threads - 1,665 Posts (average 0.35 Posts per Day)