You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by schlaiss (Jul 1st 2010, 9:25pm)

1 353

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 352

by hi.todd

(Jun 19th 2009, 10:23pm)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 348

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 345

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by Mindy (Aug 23rd 2011, 12:33pm)

1 345

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by Eclectic (May 17th 2010, 2:01pm)

0 341

No reply

by killerj (May 25th 2009, 10:32am)

0 339

No reply

by JimB (Jul 30th 2011, 3:59pm)

1 338

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by Evergreen Sprinkler (Aug 4th 2015, 5:43pm)

0 335

No reply

by ddunkley (Jun 8th 2015, 3:57pm)

1 334

by Wet_Boots

(Jun 8th 2015, 4:58pm)

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)