You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by (May 13th 2006, 9:21am)

1 986

by jmduke7

(Aug 17th 2006, 3:13pm)

by gerald (May 31st 2006, 5:44am)

2 307

by jmduke7

(Aug 17th 2006, 3:03pm)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,311

by jmduke7

(Aug 17th 2006, 3:00pm)

by sprinklerookie (Jun 6th 2006, 5:21am)

1 302

by jmduke7

(Aug 16th 2006, 6:36pm)

by bobottolini (Jul 10th 2006, 12:27pm)

3 447

by jmduke7

(Aug 16th 2006, 6:30pm)

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 704

by mrfixit

(Aug 7th 2006, 1:26am)

by gregson (Jul 22nd 2006, 10:14am)

2 282

by nestors

(Aug 2nd 2006, 6:26pm)

by (Apr 9th 2006, 5:52pm)

3 452

by xpedient

(Jul 2nd 2006, 3:34pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 672

No reply

by Audit (Jun 14th 2006, 2:16am)

1 324

by xpedient

(Jun 25th 2006, 6:27pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)