You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kmofleh (Nov 3rd 2014, 4:24pm)

1 234

by kmofleh

(Nov 3rd 2014, 4:36pm)

by JimB (Jul 30th 2011, 3:59pm)

1 231

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by Mindy (Aug 23rd 2011, 12:33pm)

1 229

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by wetyet (Apr 6th 2006, 4:16pm)

2 228

by wetyet

(Apr 7th 2006, 4:01pm)

by mikem (Jan 4th 2004, 7:33pm)

0 227

No reply

by Eclectic (May 17th 2010, 2:01pm)

0 225

No reply

by lloydlevy (Nov 28th 2011, 1:34pm)

1 218

by Wet_Boots

(Nov 28th 2011, 3:46pm)

by jstanley (Aug 30th 2005, 5:37pm)

1 210

by SprinklerGuy

(Sep 6th 2005, 7:09am)

by dan2125 (Apr 10th 2004, 2:17pm)

1 206

by RVLI

(Apr 13th 2004, 5:30pm)

by LT87 (May 21st 2014, 11:33am)

3 205

by hi.todd

(May 27th 2014, 1:03pm)

Show

Statistics:

465 Threads - 1,754 Posts (average 0.36 Posts per Day)