You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by trs (Aug 4th 2015, 7:38pm)

2 1,165

by Evergreen Sprinkler

(Aug 7th 2015, 1:34pm)

by cassian (Aug 16th 2005, 6:44am)

1 1,169

by RidgeRun05

(Aug 16th 2005, 1:28pm)

by LawnJockey (Oct 29th 2011, 10:39am)

1 1,176

by mrfixit

(Oct 29th 2011, 1:33pm)

by guill34 (Jun 4th 2007, 6:49am)

2 1,178

by guill34

(Jun 4th 2007, 1:11pm)

by zenavttmn (Apr 22nd 2006, 9:25am)

5 1,182

by zenavttmn

(Apr 24th 2006, 1:21pm)

by whitty (Apr 20th 2012, 8:09am)

10 1,202

by GatorGuy

(Apr 23rd 2012, 8:45am)

by mdige (Oct 31st 2011, 4:31pm)

1 1,203

by Wet_Boots

(Nov 1st 2011, 6:36am)

by betsycam (Oct 13th 2013, 4:26pm)

1 1,205

by Wet_Boots

(Oct 14th 2013, 10:18am)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 1,207

by jmduke7

(Aug 17th 2006, 3:13pm)

by ragtop69 (Oct 12th 2012, 7:11pm)

1 1,208

by Wet_Boots

(Oct 12th 2012, 10:24pm)

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)