You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 378

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by ahersman (Sep 30th 2009, 1:37pm)

1 378

by ahersman

(Sep 30th 2009, 6:15pm)

by tabong (Jun 18th 2006, 5:10pm)

1 378

by Wet_Boots

(Jun 19th 2006, 5:44am)

by Towelie427 (Sep 1st 2014, 7:10pm)

4 377

by Wet_Boots

(Oct 5th 2014, 2:45pm)

by rose (Sep 11th 2012, 12:24pm)

0 377

No reply

by schlaiss (Jul 1st 2010, 9:25pm)

1 372

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by frankmanic (Aug 5th 2010, 8:44am)

0 371

No reply

by jhardwick (Jun 10th 2006, 1:26pm)

0 371

No reply

by mugentuner (Aug 30th 2004, 12:30pm)

1 370

by mugentuner

(Sep 6th 2004, 8:44am)

by Evergreen Sprinkler (Aug 4th 2015, 5:43pm)

0 368

No reply

Show

Statistics:

517 Threads - 1,975 Posts (average 0.37 Posts per Day)