You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by betsycam (Oct 13th 2013, 4:26pm)

1 457

by Wet_Boots

(Oct 14th 2013, 10:18am)

by nowaterflow (Mar 8th 2013, 3:52pm)

3 298

by Wet_Boots

(Mar 9th 2013, 3:46pm)

by peterheading (Oct 25th 2005, 5:03pm)

2 215

by Wet_Boots

(Oct 27th 2005, 2:43am)

by richard1975 (Apr 28th 2013, 7:12pm)

1 213

by Scott76

(May 2nd 2013, 2:06pm)

by hadaX (Aug 28th 2014, 11:06am)

2 66

by irrigirl

(Aug 29th 2014, 5:33pm)

by jimmyburg (Oct 2nd 2007, 7:22am)

0 288

No reply

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 170

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by zenavttmn (Apr 22nd 2006, 9:25am)

5 624

by zenavttmn

(Apr 24th 2006, 1:21pm)

by ncampbel (Jul 1st 2011, 2:15pm)

1 669

by Mitchgo

(Jul 1st 2011, 9:20pm)

by tabong (Jun 18th 2006, 5:10pm)

1 165

by Wet_Boots

(Jun 19th 2006, 5:44am)

Show

Statistics:

436 Threads - 1,654 Posts (average 0.36 Posts per Day)