You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by melprint (Jul 11th 2009, 9:06am)

1 416

by mrfixit

(Jul 11th 2009, 11:59am)

by wingnut (Jul 9th 2009, 10:29pm)

1 402

by mrfixit

(Jul 10th 2009, 2:31pm)

by trapkoch (Jul 5th 2009, 10:20am)

1 496

by mrfixit

(Jul 5th 2009, 12:46pm)

by George_S (Jun 26th 2009, 7:13pm)

0 353

No reply

by EtzGx (Jun 21st 2009, 12:40pm)

0 646

No reply

by bbruck (Jun 20th 2009, 7:11pm)

1 1,639

by Wet_Boots

(Jun 21st 2009, 8:31am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 377

by hi.todd

(Jun 19th 2009, 10:29pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 573

by hi.todd

(Jun 19th 2009, 10:24pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 329

by hi.todd

(Jun 19th 2009, 10:23pm)

by killerj (May 25th 2009, 10:32am)

0 320

No reply

Show

Statistics:

506 Threads - 1,938 Posts (average 0.37 Posts per Day)