You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rickesco (Jul 28th 2004, 8:13am)

3 148

by aquamatic

(Jul 29th 2004, 10:36am)

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 150

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by jmm1804 (Jun 20th 2004, 2:34pm)

0 76

No reply

by jmm1804 (Jun 3rd 2004, 11:49am)

2 204

by jmm1804

(Jun 7th 2004, 12:53pm)

by dan2125 (Apr 10th 2004, 2:17pm)

1 102

by RVLI

(Apr 13th 2004, 5:30pm)

by boosted50 (Mar 18th 2004, 4:55am)

5 419

by boosted50

(Mar 20th 2004, 1:24pm)

by jlynnrose (Mar 16th 2004, 1:33pm)

1 208

by RVLI

(Mar 16th 2004, 2:57pm)

by Rendaug (Jan 18th 2004, 12:31pm)

3 184

by Rendaug

(Feb 8th 2004, 10:37am)

by paterjb (Jan 5th 2004, 7:46am)

5 260

by RVLI

(Jan 6th 2004, 3:16pm)

by mikem (Jan 4th 2004, 7:33pm)

0 160

No reply

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)