You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by SteveM099 (Jun 19th 2006, 1:50am)

1 351

by Wet_Boots

(Jun 19th 2006, 6:17am)

by tabong (Jun 18th 2006, 5:10pm)

1 330

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 368

by SteveM099

(Jun 15th 2006, 2:21pm)

by jhardwick (Jun 10th 2006, 1:26pm)

0 329

No reply

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 523

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by sgb (Jun 5th 2006, 5:30pm)

0 639

No reply

by Rick Hudspeth (May 31st 2006, 5:13am)

2 798

by Rick Hudspeth

(May 31st 2006, 7:35am)

by Leah Heimdahl (May 4th 2006, 4:47pm)

4 630

by DOORZ

(May 31st 2006, 6:50am)

by archiejobs (May 31st 2006, 4:18am)

2 479

by archiejobs

(May 31st 2006, 4:24am)

by Sandart (May 25th 2006, 3:16pm)

2 411

by jlease

(May 28th 2006, 10:06am)

Show

Statistics:

497 Threads - 1,879 Posts (average 0.36 Posts per Day)