You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by betsycam (Oct 13th 2013, 4:26pm)

1 433

by Wet_Boots

(Oct 14th 2013, 10:18am)

by beachdoc (May 19th 2012, 1:37pm)

5 954

by pavelow

(Oct 30th 2013, 9:51pm)

by JT (Mar 9th 2014, 8:08pm)

1 168

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by PerryNZ (Mar 12th 2014, 10:57pm)

5 185

by PerryNZ

(Mar 14th 2014, 12:16am)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 180

by mrfixit

(Mar 22nd 2014, 1:58am)

by JAshburn (Apr 23rd 2014, 10:04pm)

3 103

by Wet_Boots

(Apr 24th 2014, 4:22pm)

by andyl (Apr 21st 2014, 8:32pm)

3 132

by Wet_Boots

(Apr 27th 2014, 9:26am)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 166

No reply

by abcoker (May 9th 2014, 2:43pm)

5 147

by Wet_Boots

(May 23rd 2014, 7:04am)

by noquarter (May 24th 2014, 1:22pm)

6 94

by Wet_Boots

(May 26th 2014, 6:22am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)