You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by ash13 (Jun 1st 2014, 10:06am)

4 151

by Central Irrigation

(Jun 1st 2014, 6:17pm)

by JimB (Jul 30th 2011, 3:59pm)

1 151

by Wet_Boots

(Jul 30th 2011, 4:53pm)

by Fisher (Aug 7th 2010, 5:43pm)

0 150

No reply

by andyl (Apr 21st 2014, 8:32pm)

3 149

by Wet_Boots

(Apr 27th 2014, 9:26am)

by Mindy (Aug 23rd 2011, 12:33pm)

1 147

by Wet_Boots

(Aug 23rd 2011, 2:30pm)

by Roger Stover (Jun 16th 2009, 11:09am)

4 142

by hi.todd

(Jun 19th 2009, 10:27pm)

by horse_98 (Aug 22nd 2011, 4:03pm)

2 140

by Wet_Boots

(Aug 23rd 2011, 11:43am)

by jstanley (Aug 30th 2005, 5:37pm)

1 139

by SprinklerGuy

(Sep 6th 2005, 7:09am)

by lloydlevy (Nov 28th 2011, 1:34pm)

1 134

by Wet_Boots

(Nov 28th 2011, 3:46pm)

by 68watford (Apr 30th 2006, 9:14am)

0 134

No reply

Show

Statistics:

436 Threads - 1,648 Posts (average 0.36 Posts per Day)