You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mdige (Oct 31st 2011, 4:31pm)

1 1,014

by Wet_Boots

(Nov 1st 2011, 6:36am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 1,015

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by Bob B (Oct 18th 2014, 9:31am)

17 1,016

by Wet_Boots

(Nov 1st 2014, 6:44am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 1,017

by ddeferra

(Jun 8th 2011, 6:29pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 1,041

by hi.todd

(Aug 10th 2010, 11:57am)

by davew (Jul 4th 2005, 11:17am)

2 1,047

by davew

(Jul 5th 2005, 10:54am)

by ksrmc (Aug 1st 2012, 3:27pm)

6 1,048

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Shred Happy (Dec 21st 2011, 9:04am)

1 1,068

by Wet_Boots

(Dec 21st 2011, 12:54pm)

by Trabecca (Mar 13th 2013, 6:22pm)

7 1,072

by Trabecca

(Mar 18th 2013, 8:23am)

by guill34 (Jun 4th 2007, 6:49am)

2 1,075

by guill34

(Jun 4th 2007, 1:11pm)

Show

Statistics:

497 Threads - 1,878 Posts (average 0.36 Posts per Day)