You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by sprinklerookie (Jun 6th 2006, 5:21am)

1 345

by jmduke7

(Aug 16th 2006, 6:36pm)

by paterjb (Jan 5th 2004, 7:46am)

5 558

by RVLI

(Jan 6th 2004, 3:16pm)

by tmshead (Oct 1st 2007, 4:35am)

2 541

by Wet_Boots

(Oct 3rd 2007, 6:52am)

by trapkoch (Jul 5th 2009, 10:20am)

1 476

by mrfixit

(Jul 5th 2009, 12:46pm)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,357

by PhoenixDen

(Jun 24th 2010, 11:27am)

by jbbnet (Aug 19th 2004, 5:11pm)

3 357

by SamIV

(Aug 29th 2004, 5:43am)

by andyl (Apr 21st 2014, 8:32pm)

3 391

by Wet_Boots

(Apr 27th 2014, 9:26am)

by Jonas_ (Mar 14th 2012, 6:16am)

1 638

by GatorGuy

(Mar 14th 2012, 7:35am)

by peetey37 (May 22nd 2006, 7:17am)

1 438

by nestors

(May 27th 2006, 5:31pm)

by Dennis (Oct 15th 2007, 7:30am)

1 857

by edwildesr

(Nov 5th 2007, 7:53am)

Show

Statistics:

500 Threads - 1,901 Posts (average 0.37 Posts per Day)