You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tabong (Jun 18th 2006, 5:10pm)

1 260

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 288

by SteveM099

(Jun 15th 2006, 2:21pm)

by bzook@aol.com (Jun 8th 2006, 1:47pm)

1 442

by Wet_Boots

(Jun 8th 2006, 3:46pm)

by peetey37 (May 22nd 2006, 7:17am)

1 368

by nestors

(May 27th 2006, 5:31pm)

by keitht (Apr 11th 2006, 3:53pm)

1 280

by BSME

(Apr 12th 2006, 5:45am)

by jstanley (Aug 30th 2005, 5:37pm)

1 218

by SprinklerGuy

(Sep 6th 2005, 7:09am)

by grph (Aug 31st 2005, 3:56am)

1 306

by Jazzer K

(Sep 2nd 2005, 6:25pm)

by PATS (Aug 17th 2005, 2:22am)

1 361

by Wet_Boots

(Aug 17th 2005, 2:45am)

by cassian (Aug 16th 2005, 6:44am)

1 946

by RidgeRun05

(Aug 16th 2005, 1:28pm)

by bombertennis (Jul 9th 2005, 3:20pm)

1 379

by Wet_Boots

(Jul 9th 2005, 3:57pm)

Show

Statistics:

475 Threads - 1,785 Posts (average 0.36 Posts per Day)