You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by frankmanic (Aug 5th 2010, 8:44am)

0 364

No reply

by kingtpt (Jul 17th 2010, 5:57pm)

5 560

by Fireguy97

(Jul 18th 2010, 11:35pm)

by RodQ (Jul 11th 2010, 12:54pm)

2 425

by hi.todd

(Jul 12th 2010, 12:49pm)

by schlaiss (Jul 1st 2010, 9:25pm)

1 353

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Kim (Jun 19th 2010, 6:45am)

1 394

by mrfixit

(Jun 19th 2010, 12:11pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 489

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 523

by mrfixit

(Jun 4th 2010, 7:49pm)

by Merv (May 1st 2010, 3:44pm)

3 622

by mrfixit

(May 31st 2010, 9:47pm)

by KSknight (Aug 17th 2009, 10:53am)

1 830

by bdbengtsson

(May 21st 2010, 5:27pm)

by Eclectic (May 17th 2010, 2:01pm)

0 341

No reply

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)