You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by mharden5 (Jul 11th 2009, 12:45pm)

1 368

by hi.todd

(Jul 11th 2009, 9:27pm)

by melprint (Jul 11th 2009, 9:06am)

1 397

by mrfixit

(Jul 11th 2009, 11:59am)

by wingnut (Jul 9th 2009, 10:29pm)

1 384

by mrfixit

(Jul 10th 2009, 2:31pm)

by trapkoch (Jul 5th 2009, 10:20am)

1 470

by mrfixit

(Jul 5th 2009, 12:46pm)

by George_S (Jun 26th 2009, 7:13pm)

0 336

No reply

by EtzGx (Jun 21st 2009, 12:40pm)

0 620

No reply

by bbruck (Jun 20th 2009, 7:11pm)

1 1,246

by Wet_Boots

(Jun 21st 2009, 8:31am)

by Hammy69 (Jun 16th 2009, 9:46am)

1 355

by hi.todd

(Jun 19th 2009, 10:29pm)

by d leimer (Jun 14th 2009, 11:45pm)

2 543

by hi.todd

(Jun 19th 2009, 10:24pm)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 310

by hi.todd

(Jun 19th 2009, 10:23pm)

Show

Statistics:

497 Threads - 1,877 Posts (average 0.36 Posts per Day)