You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by tico (Jun 15th 2013, 8:58pm)

0 731

No reply

by 7907 (May 3rd 2013, 12:55am)

2 467

by PennyInHeels

(Jun 25th 2013, 9:49am)

by WHomeowner (Jul 24th 2011, 2:16pm)

10 2,654

by PennyInHeels

(Jun 25th 2013, 3:52pm)

by BessMan94 (Jun 24th 2013, 8:45pm)

3 631

by mrfixit

(Jun 25th 2013, 8:32pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 906

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by Pippilo (Jul 1st 2013, 9:15pm)

3 630

by mrfixit

(Jul 2nd 2013, 3:07am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 1,038

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by cjohnson2020 (Jul 26th 2013, 4:31pm)

2 455

by mrfixit

(Jul 27th 2013, 2:59am)

by pjmckellar (Jul 27th 2013, 8:25am)

1 418

by Central Irrigation

(Jul 27th 2013, 9:42am)

by sdguy (Mar 10th 2013, 3:15pm)

3 740

by Wet_Boots

(Jul 31st 2013, 10:41am)

Show

Statistics:

500 Threads - 1,903 Posts (average 0.37 Posts per Day)