You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by dgaines (Nov 5th 2012, 5:27pm)

3 986

by dgaines

(Nov 10th 2012, 4:15pm)

by LawnJockey (Oct 29th 2011, 10:39am)

1 990

by mrfixit

(Oct 29th 2011, 1:33pm)

by Mac54321 (Jul 13th 2011, 10:03am)

1 991

by Wet_Boots

(Jul 13th 2011, 11:30am)

by John199 (Aug 14th 2011, 3:57pm)

4 996

by hi.todd

(Aug 15th 2011, 7:29pm)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 1,000

by mrfixit

(Jun 10th 2012, 8:13pm)

by crashxx (Apr 28th 2012, 12:16pm)

4 1,006

by crashxx

(May 1st 2012, 9:15am)

by orgits (Apr 9th 2011, 5:10pm)

2 1,025

by Mitchgo

(Apr 10th 2011, 2:29am)

by Bob H (May 13th 2003, 12:54am)

17 1,033

by Bob H

(Jun 3rd 2003, 9:20am)

by jkd1976@yahoo.com (Mar 15th 2007, 4:11pm)

7 1,044

by SprinklerGuy

(Mar 17th 2007, 2:22am)

by BVISailor (Oct 31st 2009, 10:11am)

1 1,057

by worachj

(Oct 31st 2009, 12:47pm)

Show

Statistics:

465 Threads - 1,754 Posts (average 0.36 Posts per Day)