You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by pjansen19 (Nov 7th 2011, 4:18pm)

3 928

by mrfixit

(Nov 10th 2011, 4:23am)

by mdige (Oct 31st 2011, 4:31pm)

1 929

by Wet_Boots

(Nov 1st 2011, 6:36am)

by ddeferra (Jun 7th 2011, 10:46pm)

2 935

by ddeferra

(Jun 8th 2011, 6:29pm)

by ksrmc (Aug 1st 2012, 3:27pm)

6 937

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by whitty (Apr 20th 2012, 8:09am)

10 943

by GatorGuy

(Apr 23rd 2012, 8:45am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 952

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 989

by hi.todd

(Aug 10th 2010, 11:57am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 995

by Trabecca

(Mar 18th 2013, 8:23am)

by davew (Jul 4th 2005, 11:17am)

2 998

by davew

(Jul 5th 2005, 10:54am)

by cassian (Aug 16th 2005, 6:44am)

1 1,008

by RidgeRun05

(Aug 16th 2005, 1:28pm)



482 Threads - 1,813 Posts (average 0.36 Posts per Day)