You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Trabecca (Mar 13th 2013, 6:22pm)

7 928

by Trabecca

(Mar 18th 2013, 8:23am)

by davew (Jul 4th 2005, 11:17am)

2 931

by davew

(Jul 5th 2005, 10:54am)

by Eastern chubbytool (Aug 8th 2010, 2:49pm)

2 933

by hi.todd

(Aug 10th 2010, 11:57am)

by pohall@kivexmail.com (May 13th 2006, 9:21am)

1 933

by jmduke7

(Aug 17th 2006, 3:13pm)

by guill34 (Jun 4th 2007, 6:49am)

2 940

by guill34

(Jun 4th 2007, 1:11pm)

by cassian (Aug 16th 2005, 6:44am)

1 946

by RidgeRun05

(Aug 16th 2005, 1:28pm)

by kenttab (May 21st 2012, 5:51pm)

1 977

by mrfixit

(May 21st 2012, 8:58pm)

by ragtop69 (Oct 12th 2012, 7:11pm)

1 980

by Wet_Boots

(Oct 12th 2012, 10:24pm)

by Shred Happy (Dec 21st 2011, 9:04am)

1 988

by Wet_Boots

(Dec 21st 2011, 12:54pm)

by labert (Jan 3rd 2004, 6:11am)

3 988

by labert

(Jan 7th 2004, 2:15pm)

Show

Statistics:

476 Threads - 1,790 Posts (average 0.36 Posts per Day)