You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 149

by hi.todd

(Jun 19th 2009, 10:23pm)

by tabong (Jun 18th 2006, 5:10pm)

1 149

by Wet_Boots

(Jun 19th 2006, 5:44am)

by bron7fan@cox.net (Oct 15th 2011, 5:15pm)

2 147

by mrfixit

(Oct 16th 2011, 2:26am)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 146

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 145

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by gregson (Jul 22nd 2006, 10:14am)

2 145

by nestors

(Aug 2nd 2006, 6:26pm)

by Eclectic (May 17th 2010, 2:01pm)

0 144

No reply

by porterville cemetery (Nov 1st 2011, 2:23pm)

1 143

by Wet_Boots

(Nov 1st 2011, 3:12pm)

by jbbnet (Aug 19th 2004, 5:11pm)

3 141

by SamIV

(Aug 29th 2004, 5:43am)

by JimB (Jul 30th 2011, 3:59pm)

1 137

by Wet_Boots

(Jul 30th 2011, 4:53pm)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)