You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by GT6812 (Aug 28th 2015, 8:40am)

2 407

by GT6812

(Aug 31st 2015, 11:15am)

by Bert Wall (Jan 23rd 2007, 7:40am)

5 695

by Wet_Boots

(Jan 25th 2007, 12:56pm)

by glmcolo (Nov 27th 2006, 4:32am)

1 463

by Wet_Boots

(Nov 27th 2006, 6:04am)

by MAG128 (Jun 24th 2015, 5:32pm)

3 291

by Wet_Boots

(Jun 26th 2015, 6:20am)

by wkneis@optonline.net (Apr 9th 2006, 5:52pm)

3 579

by xpedient

(Jul 2nd 2006, 3:34pm)

by Jlivengood (Oct 20th 2012, 2:01am)

3 924

by Wet_Boots

(Oct 20th 2012, 5:11pm)

by sirlar (Jul 20th 2012, 2:40pm)

0 370

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 1,477

by Mitchgo

(Apr 10th 2011, 2:29am)

by kgb9251@nc.rr.com (Jul 18th 2011, 5:26pm)

1 715

by Mitchgo

(Jul 19th 2011, 12:34am)

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 197

No reply

Show

Statistics:

513 Threads - 1,964 Posts (average 0.37 Posts per Day)