You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by kazemi (Sep 5th 2005, 11:57am)

3 466

by Wet_Boots

(Sep 5th 2005, 2:14pm)

by Rmiclette (May 5th 2013, 6:49am)

2 452

by Scott76

(May 5th 2013, 11:41am)

by veidtmeister (Jul 29th 2011, 2:02pm)

9 680

by Wet_Boots

(Jul 31st 2011, 3:08pm)

by wingnut (Jul 9th 2009, 10:29pm)

1 331

by mrfixit

(Jul 10th 2009, 2:31pm)

by jmm1804 (Jun 3rd 2004, 11:49am)

2 394

by jmm1804

(Jun 7th 2004, 12:53pm)

by rrsteve (Aug 22nd 2002, 9:53pm)

1 468

by Rays Sprinklers

(May 22nd 2003, 4:13am)

by kmofleh (Nov 3rd 2014, 4:24pm)

1 254

by kmofleh

(Nov 3rd 2014, 4:36pm)

by xfevv (Oct 16th 2007, 4:52am)

4 807

by Cricketkiller

(Jun 7th 2008, 3:53pm)

by RT (Oct 12th 2011, 8:10pm)

1 825

by mrfixit

(Oct 12th 2011, 11:29pm)

by SteveM099 (Jun 15th 2006, 2:09pm)

1 319

by SteveM099

(Jun 15th 2006, 2:21pm)



479 Threads - 1,805 Posts (average 0.36 Posts per Day)