You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by JT (Mar 9th 2014, 8:08pm)

1 175

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by carolinagirl (Aug 29th 2014, 5:00pm)

4 72

by irrigirl

(Sep 2nd 2014, 1:19pm)

by BRL (Jun 13th 2007, 2:03pm)

0 1,545

No reply

by lou40 (Nov 9th 2011, 4:15pm)

3 597

by Wet_Boots

(Nov 13th 2011, 8:15am)

by bobspitler (Jun 6th 2011, 7:10am)

1 303

by Mitchgo

(Jun 6th 2011, 9:34pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 428

by Wet_Boots

(Jul 31st 2013, 10:41am)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 316

by mrfixit

(Aug 14th 2013, 12:28pm)

by lily (May 20th 2006, 9:31pm)

4 486

by daniels

(Aug 7th 2007, 11:00am)

by Merv (May 1st 2010, 3:44pm)

3 339

by mrfixit

(May 31st 2010, 9:47pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 390

by HooKooDooKu

(Jul 1st 2009, 11:31am)

Show

Statistics:

436 Threads - 1,650 Posts (average 0.36 Posts per Day)