You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by noquarter (May 24th 2014, 1:22pm)

6 110

by Wet_Boots

(May 26th 2014, 6:22am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 562

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by rsteffan (Aug 1st 2012, 6:14pm)

6 516

by Wet_Boots

(Aug 22nd 2012, 10:52am)

by ksrmc (Aug 1st 2012, 3:27pm)

6 494

by Wet_Boots

(Aug 2nd 2012, 9:31am)

by Rsnic (Jun 17th 2012, 2:10pm)

6 2,001

by Wet_Boots

(Jun 20th 2012, 10:13am)

by alabama8100 (Jun 8th 2012, 1:35pm)

6 1,597

by GatorGuy

(Jun 11th 2012, 8:38am)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 423

by CRI IRR

(Sep 13th 2011, 6:34am)

by denm31 (Apr 4th 2011, 3:11pm)

6 497

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by Buff (Jun 6th 2008, 8:25am)

6 3,141

by mrfixit

(Jun 6th 2008, 1:59pm)

by julieblades (Jan 7th 2006, 6:27am)

6 210

by Mudpuppy

(Oct 12th 2006, 6:03pm)

Show

Statistics:

436 Threads - 1,650 Posts (average 0.36 Posts per Day)