You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by nrwe (Jul 19th 2012, 1:57pm)

4 492

by mrfixit

(Jul 20th 2012, 3:06pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 1,855

by Wet_Boots

(Jun 20th 2012, 10:13am)

by Jonas_ (Mar 13th 2012, 9:40am)

10 1,762

by Wet_Boots

(Mar 16th 2012, 8:14am)

by hudr0004 (Sep 12th 2011, 10:16am)

4 493

by hudr0004

(Oct 24th 2011, 8:38am)

by hockeyist77 (Sep 1st 2011, 6:21pm)

4 814

by hockeyist77

(Sep 7th 2011, 3:47pm)

by bluetractormanc (Aug 9th 2011, 10:59pm)

1 634

by Wet_Boots

(Aug 10th 2011, 7:51am)

by jackh (Jun 12th 2011, 11:57am)

9 2,532

by Wet_Boots

(Jun 13th 2011, 9:17am)

by JeakeVerent (Jun 11th 2011, 8:46pm)

3 2,149

by Mitchgo

(Jun 12th 2011, 2:13pm)

by bherholz (May 16th 2011, 12:06pm)

5 961

by mrfixit

(Jun 7th 2011, 5:46pm)

by t_shea (Sep 18th 2010, 10:46am)

5 2,347

by Wet_Boots

(Sep 20th 2010, 1:01pm)

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)