You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by JT (Mar 9th 2014, 8:08pm)

1 478

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by edwildesr (Oct 7th 2007, 7:02pm)

2 1,993

by mrfixit

(Aug 26th 2013, 8:00pm)

by tico (Jun 15th 2013, 8:58pm)

0 713

No reply

by gobris (May 14th 2013, 9:45am)

3 735

by Wet_Boots

(May 16th 2013, 8:30am)

by Sartenose (Sep 22nd 2012, 2:31pm)

1 664

by Wet_Boots

(Sep 22nd 2012, 10:06pm)

by Bonelawr (Jul 29th 2012, 9:45am)

2 356

by Bonelawr

(Jul 29th 2012, 11:38am)

by nrwe (Jul 19th 2012, 1:57pm)

4 880

by mrfixit

(Jul 20th 2012, 3:06pm)

by alabama8100 (Jun 8th 2012, 1:35pm)

6 2,711

by GatorGuy

(Jun 11th 2012, 8:38am)

by harrisst14 (Jun 10th 2012, 6:29pm)

1 1,188

by mrfixit

(Jun 10th 2012, 8:13pm)

by kannan (May 18th 2011, 5:07pm)

4 1,836

by Wet_Boots

(May 27th 2012, 10:31am)

Show

Statistics:

497 Threads - 1,879 Posts (average 0.36 Posts per Day)