You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by Moggie (Jun 4th 2011, 10:48am)

1 457

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 666

by Mitchgo

(Jun 4th 2011, 3:32pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 586

by Mitchgo

(May 9th 2011, 1:04am)

by jchsmiller (Apr 18th 2011, 11:47am)

1 499

by Wet_Boots

(Apr 20th 2011, 12:27pm)

by g (Apr 19th 2011, 1:56pm)

0 336

No reply

by orgits (Apr 9th 2011, 5:10pm)

2 1,719

by Mitchgo

(Apr 10th 2011, 2:29am)

by joe decoste (Mar 19th 2011, 11:56am)

1 408

by Wet_Boots

(Mar 20th 2011, 7:29am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 751

by hi.todd

(Feb 27th 2011, 4:12pm)

by william62949 (Oct 10th 2010, 2:56pm)

1 522

by mrfixit

(Oct 10th 2010, 6:02pm)

by shellbeach (Sep 27th 2010, 4:18pm)

2 455

by Wet_Boots

(Sep 28th 2010, 1:11pm)



518 Threads - 1,977 Posts (average 0.37 Posts per Day)