You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Sebastian2015 (Jul 28th 2015, 9:27am)

1 186

by Wet_Boots

(Jul 28th 2015, 11:15am)

by Jamie (Jul 29th 2015, 6:17pm)

1 193

by mrfixit

(Jul 29th 2015, 11:48pm)

by john_00 (Jan 16th 2016, 1:53pm)

7 194

by Wet_Boots

(Jan 19th 2016, 9:09am)

by ScorpioTravis (Aug 10th 2015, 1:06pm)

0 195

No reply

by LX2 (Jul 16th 2015, 3:14pm)

2 198

by LX2

(Jul 17th 2015, 8:27am)

by rickbrum (Apr 18th 2016, 9:13am)

4 200

by hoosudaddy

(May 13th 2016, 3:13pm)

by joeywfl (Jun 15th 2015, 8:34am)

1 200

by Wet_Boots

(Jun 15th 2015, 9:02am)

by DeadImperial (May 22nd 2016, 8:17pm)

20 202

by Wet_Boots

(May 29th 2016, 3:15am)

by terryn (Jan 18th 2016, 9:07pm)

6 208

by mrfixit

(Jan 22nd 2016, 11:23pm)

by CRASH (Aug 6th 2015, 6:02pm)

3 211

by Wet boots

(Aug 7th 2015, 3:30pm)

Show

Statistics:

508 Threads - 1,950 Posts (average 0.37 Posts per Day)