You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bobottolini (Jul 10th 2006, 12:27pm)

3 246

by jmduke7

(Aug 16th 2006, 6:30pm)

by whitty (Apr 20th 2012, 8:09am)

10 404

by GatorGuy

(Apr 23rd 2012, 8:45am)

by denm31 (Apr 4th 2011, 3:11pm)

6 347

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by TheEngineer (Sep 14th 2005, 5:44pm)

4 212

by lush96

(Mar 19th 2006, 8:13pm)

by nrwe (Jul 19th 2012, 1:57pm)

4 404

by mrfixit

(Jul 20th 2012, 3:06pm)

by fatelvis00 (Aug 4th 2006, 2:58pm)

1 450

by mrfixit

(Aug 7th 2006, 1:26am)

by Sandart (May 25th 2006, 3:16pm)

2 179

by jlease

(May 28th 2006, 10:06am)

by skimi (May 6th 2008, 12:27am)

5 1,999

by jbsbeach

(Jan 7th 2009, 7:18am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 387

by Trabecca

(Mar 18th 2013, 8:23am)

by badsprinklers (Oct 10th 2007, 4:55pm)

12 1,846

by Wet_Boots

(Apr 27th 2008, 11:09am)

Show

Statistics:

420 Threads - 1,567 Posts (average 0.35 Posts per Day)