You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by BayAreaFlyer (Feb 9th 2016, 2:17pm)

2 514

by Wet_Boots

(Feb 9th 2016, 5:28pm)

by donna (Feb 6th 2016, 2:47pm)

8 246

by donna

(Feb 9th 2016, 12:29pm)

by terryn (Jan 18th 2016, 9:07pm)

6 218

by mrfixit

(Jan 22nd 2016, 11:23pm)

by john_00 (Jan 16th 2016, 1:53pm)

7 207

by Wet_Boots

(Jan 19th 2016, 9:09am)

by dsmayse (Oct 24th 2015, 10:43am)

3 839

by Wet_Boots

(Oct 25th 2015, 5:55pm)

by Lonesomedave (Oct 16th 2015, 7:38am)

1 433

by Wet_Boots

(Oct 16th 2015, 10:46am)

by 09KR0058 (Oct 13th 2015, 6:11pm)

1 235

by 09KR0058

(Oct 13th 2015, 6:42pm)

by MichaelABQ (Sep 15th 2015, 1:11am)

1 233

by mrfixit

(Sep 15th 2015, 4:19am)

by Dagobah (Sep 3rd 2015, 3:46pm)

3 789

by Evergreen Sprinkler

(Sep 11th 2015, 9:41am)

by 88goldwing (Sep 1st 2015, 2:28pm)

12 793

by 88goldwing

(Sep 8th 2015, 5:36pm)

Show

Statistics:

516 Threads - 1,973 Posts (average 0.37 Posts per Day)