You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by lbfalgi (Aug 30th 2011, 6:15pm)

1 985

by Central Irrigation

(Aug 30th 2011, 8:38pm)

by Marvel (Jan 19th 2013, 6:54am)

7 1,047

by Marvel

(Jan 22nd 2013, 7:49pm)

by asegal (Oct 5th 2006, 7:43am)

4 1,066

by asegal

(Oct 6th 2006, 10:52am)

by larbec7 (Jun 6th 2009, 5:07pm)

9 1,067

by Wet_Boots

(Jun 9th 2009, 12:52pm)

by bherholz (May 16th 2011, 12:06pm)

5 1,072

by mrfixit

(Jun 7th 2011, 5:46pm)

by svsprinklers (May 19th 2010, 9:29pm)

2 1,096

by PhoenixDen

(Jun 24th 2010, 11:27am)

by korangu2004 (Aug 16th 2006, 5:56pm)

3 1,100

by jmduke7

(Aug 17th 2006, 3:00pm)

by beachdoc (May 19th 2012, 1:37pm)

5 1,101

by pavelow

(Oct 30th 2013, 9:51pm)

by lawnnovice (Jul 5th 2010, 3:03pm)

3 1,107

by Wet_Boots

(Jul 6th 2010, 7:00pm)

by krantzr (Apr 30th 2011, 8:26am)

3 1,188

by mrfixit

(May 1st 2011, 11:34am)

Show

Statistics:

440 Threads - 1,685 Posts (average 0.36 Posts per Day)