You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by nrwe (Jul 19th 2012, 1:57pm)

4 924

by mrfixit

(Jul 20th 2012, 3:06pm)

by rspfau (Jun 9th 2011, 6:12pm)

4 927

by Mitchgo

(Jun 9th 2011, 10:08pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 931

by Wet_Boots

(Apr 26th 2011, 9:20am)

by lonnieclar (Jul 22nd 2008, 7:06pm)

1 936

by mrfixit

(Jul 22nd 2008, 9:30pm)

by slemani62 (Jul 29th 2010, 2:56pm)

1 951

by mrfixit

(Jul 29th 2010, 6:35pm)

by Bumbleball (Sep 4th 2010, 12:15am)

10 954

by Bumbleball

(Sep 14th 2010, 9:06pm)

by patk (Sep 18th 2011, 2:17pm)

2 957

by patk

(Sep 18th 2011, 3:41pm)

by Jimy (Aug 30th 2011, 11:45am)

4 960

by chrisrlewis78

(Sep 4th 2011, 2:52pm)

by ncampbel (Jul 1st 2011, 2:15pm)

1 964

by Mitchgo

(Jul 1st 2011, 9:20pm)

by RT (Oct 12th 2011, 8:10pm)

1 971

by mrfixit

(Oct 12th 2011, 11:29pm)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)