You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rickesco (Jul 28th 2004, 8:13am)

3 126

by aquamatic

(Jul 29th 2004, 10:36am)

by mugentuner (Aug 30th 2004, 12:30pm)

1 125

by mugentuner

(Sep 6th 2004, 8:44am)

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 124

by hi.todd

(Jun 19th 2009, 10:23pm)

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 123

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by schlaiss (Jul 1st 2010, 9:25pm)

1 122

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by gerald (May 31st 2006, 5:44am)

2 120

by jmduke7

(Aug 17th 2006, 3:03pm)

by jcmckinney1 (Oct 6th 2011, 10:38am)

1 118

by Wet_Boots

(Oct 6th 2011, 6:55pm)

by BirdieBob (Aug 4th 2011, 7:01pm)

1 118

by Wet_Boots

(Aug 4th 2011, 9:27pm)

by tabong (Jun 18th 2006, 5:10pm)

1 116

by Wet_Boots

(Jun 19th 2006, 5:44am)

by SpritzCan (Apr 21st 2012, 8:33pm)

2 114

by GatorGuy

(Apr 23rd 2012, 8:47am)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)