You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by rickesco (Jul 28th 2004, 8:13am)

3 155

by aquamatic

(Jul 29th 2004, 10:36am)

by mugentuner (Aug 30th 2004, 12:30pm)

1 153

by mugentuner

(Sep 6th 2004, 8:44am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 149

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Oscar S. Ramirez (Mar 21st 2014, 5:28pm)

1 148

by mrfixit

(Mar 22nd 2014, 1:58am)

by evergreenz (Sep 3rd 2011, 2:33am)

2 147

by evergreenz

(Sep 3rd 2011, 12:08pm)

by SprinklerMaps (Apr 27th 2014, 10:13pm)

0 146

No reply

by tabong (Jun 18th 2006, 5:10pm)

1 146

by Wet_Boots

(Jun 19th 2006, 5:44am)

by Gremlin274 (Jun 12th 2005, 12:57pm)

1 146

by Wet_Boots

(Jun 12th 2005, 1:13pm)

by JT (Mar 9th 2014, 8:08pm)

1 145

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by gerald (May 31st 2006, 5:44am)

2 145

by jmduke7

(Aug 17th 2006, 3:03pm)

Show

Statistics:

431 Threads - 1,630 Posts (average 0.36 Posts per Day)