You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Caltino (Apr 12th 2013, 7:18pm)

12 661

by Wet_Boots

(Apr 27th 2013, 7:42am)

by kenken55 (Aug 5th 2010, 10:55am)

2 461

by kenken1955

(Aug 28th 2010, 5:32am)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 194

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 501

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by sbradfor (Jul 20th 2003, 7:40am)

1 183

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by jackevln (Aug 20th 2006, 6:33am)

4 294

by mrfixit

(Aug 21st 2006, 5:12pm)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 229

by Wet_Boots

(Sep 15th 2007, 12:31am)

by Sue (Aug 11th 2005, 10:47am)

4 232

by Jazzer K

(Sep 2nd 2005, 6:27pm)

by melprint (Jul 11th 2009, 9:06am)

1 223

by mrfixit

(Jul 11th 2009, 11:59am)

by donlo (Apr 18th 2006, 3:20am)

0 121

No reply

Show

Statistics:

435 Threads - 1,641 Posts (average 0.36 Posts per Day)