You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Tullamoredew1 (Jun 19th 2009, 8:24pm)

1 177

by hi.todd

(Jun 19th 2009, 10:23pm)

by Wet_Boots (May 8th 2011, 7:43am)

0 264

No reply

by bowlesev (May 30th 2007, 9:43pm)

0 127

No reply

by Caltino (Apr 12th 2013, 7:18pm)

12 843

by Wet_Boots

(Apr 27th 2013, 7:42am)

by kenken55 (Aug 5th 2010, 10:55am)

2 497

by kenken1955

(Aug 28th 2010, 5:32am)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 234

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by 4U2NVME (Jun 22nd 2013, 1:49am)

6 598

by 4U2NVME

(Jul 17th 2013, 12:01pm)

by sbradfor (Jul 20th 2003, 7:40am)

1 209

by Rays Sprinklers

(Jul 20th 2003, 7:49am)

by jackevln (Aug 20th 2006, 6:33am)

4 339

by mrfixit

(Aug 21st 2006, 5:12pm)

by ArrakeenIrrigator (Sep 14th 2007, 5:48am)

3 267

by Wet_Boots

(Sep 15th 2007, 12:31am)

Show

Statistics:

438 Threads - 1,664 Posts (average 0.36 Posts per Day)