You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by bobspitler (Jun 6th 2011, 7:10am)

1 259

by Mitchgo

(Jun 6th 2011, 9:34pm)

by sdguy (Mar 10th 2013, 3:15pm)

3 308

by Wet_Boots

(Jul 31st 2013, 10:41am)

by Bwilson2 (Aug 13th 2013, 10:12pm)

2 216

by mrfixit

(Aug 14th 2013, 12:28pm)

by lily (May 20th 2006, 9:31pm)

4 399

by daniels

(Aug 7th 2007, 11:00am)

by Merv (May 1st 2010, 3:44pm)

3 283

by mrfixit

(May 31st 2010, 9:47pm)

by lydiaE (Jun 25th 2009, 11:39am)

1 347

by HooKooDooKu

(Jul 1st 2009, 11:31am)

by water (Oct 23rd 2008, 8:47am)

1 369

by mrfixit

(Oct 23rd 2008, 10:24am)

by ArrakeenIrrigator (Sep 14th 2007, 5:52am)

3 621

by edwildesr

(Oct 7th 2007, 6:49pm)

by ohiorebel (Apr 10th 2011, 8:59am)

2 260

by Wet_Boots

(Apr 10th 2011, 4:14pm)

by Dan Mueller (Sep 15th 2007, 3:45am)

2 282

by Wet_Boots

(Sep 16th 2007, 7:55am)

Show

Statistics:

421 Threads - 1,568 Posts (average 0.35 Posts per Day)