You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by daniels (Aug 7th 2007, 11:14am)

5 3,226

by MrMark757

(Aug 9th 2010, 2:36am)

by beachdoc (May 19th 2012, 1:37pm)

5 862

by pavelow

(Oct 30th 2013, 9:51pm)

by PSpatches (Apr 28th 2009, 10:31am)

1 229

by Candance

(May 9th 2009, 9:13pm)

by csnugg (Jun 26th 2006, 4:10pm)

0 494

No reply

by nightshark (Sep 9th 2013, 3:11pm)

3 407

by mrfixit

(Sep 9th 2013, 6:05pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 1,714

by Wet_Boots

(Jun 20th 2012, 10:13am)

by JT (Mar 9th 2014, 8:08pm)

1 123

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by BRL (Jun 13th 2007, 2:03pm)

0 1,479

No reply

by lou40 (Nov 9th 2011, 4:15pm)

3 532

by Wet_Boots

(Nov 13th 2011, 8:15am)

by bobspitler (Jun 6th 2011, 7:10am)

1 278

by Mitchgo

(Jun 6th 2011, 9:34pm)

Show

Statistics:

430 Threads - 1,626 Posts (average 0.36 Posts per Day)