You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by joe decoste (Mar 19th 2011, 11:56am)

1 360

by Wet_Boots

(Mar 20th 2011, 7:29am)

by Mitchell (Feb 27th 2011, 2:26pm)

1 648

by hi.todd

(Feb 27th 2011, 4:12pm)

by Fidalgorob (Dec 4th 2010, 12:19pm)

1 625

by mrfixit

(Dec 4th 2010, 1:48pm)

by william62949 (Oct 10th 2010, 2:56pm)

1 473

by mrfixit

(Oct 10th 2010, 6:02pm)

by billt (Aug 28th 2010, 10:20am)

1 362

by Wet_Boots

(Aug 28th 2010, 11:21am)

by slemani62 (Jul 29th 2010, 2:56pm)

1 948

by mrfixit

(Jul 29th 2010, 6:35pm)

by AJ Goldsmith (Jul 21st 2010, 2:48pm)

1 2,567

by Wet_Boots

(Jul 21st 2010, 7:36pm)

by paul b (Jul 3rd 2010, 10:24am)

1 641

by Wet_Boots

(Jul 6th 2010, 9:21am)

by schlaiss (Jul 1st 2010, 9:25pm)

1 332

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Kim (Jun 19th 2010, 6:45am)

1 369

by mrfixit

(Jun 19th 2010, 12:11pm)

Show

Statistics:

505 Threads - 1,935 Posts (average 0.37 Posts per Day)