You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


by ncampbel (Jul 1st 2011, 2:15pm)

1 1,021

by Mitchgo

(Jul 1st 2011, 9:20pm)

by Ryanm519 (Jun 16th 2011, 1:28am)

1 596

by Wet_Boots

(Jun 16th 2011, 6:25am)

by Grahpack (Jun 9th 2011, 7:07pm)

1 739

by Wet_Boots

(Jun 9th 2011, 9:05pm)

by bobspitler (Jun 6th 2011, 7:10am)

1 510

by Mitchgo

(Jun 6th 2011, 9:34pm)

by Moggie (Jun 4th 2011, 10:48am)

1 452

by Mitchgo

(Jun 5th 2011, 1:28pm)

by blh (Jun 4th 2011, 12:55pm)

1 647

by Mitchgo

(Jun 4th 2011, 3:32pm)

by runningfreak (May 25th 2011, 7:32pm)

1 411

by Wet_Boots

(May 25th 2011, 8:29pm)

by AZHomeOwner (May 7th 2011, 1:35pm)

1 582

by Mitchgo

(May 9th 2011, 1:04am)

by miker (Apr 30th 2011, 12:53pm)

1 639

by Wet_Boots

(Apr 30th 2011, 2:45pm)

by ianmac (Apr 25th 2011, 10:45pm)

1 1,020

by Wet_Boots

(Apr 26th 2011, 9:20am)



517 Threads - 1,975 Posts (average 0.37 Posts per Day)