You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by alabama8100 (Jun 8th 2012, 1:35pm)

6 1,174

by GatorGuy

(Jun 11th 2012, 8:38am)

by jzb18134 (Sep 7th 2011, 3:55pm)

6 292

by CRI IRR

(Sep 13th 2011, 6:34am)

by denm31 (Apr 4th 2011, 3:11pm)

6 340

by Wet_Boots

(Apr 7th 2011, 1:00pm)

by Buff (Jun 6th 2008, 8:25am)

6 2,640

by mrfixit

(Jun 6th 2008, 1:59pm)

by julieblades (Jan 7th 2006, 6:27am)

6 129

by Mudpuppy

(Oct 12th 2006, 6:03pm)

by Kevin Dearden (Jun 14th 2003, 4:15am)

6 298

by Rays Sprinklers

(Jul 2nd 2003, 8:52am)

by Gansmanms (Nov 7th 2012, 9:10pm)

7 919

by marian

(Sep 2nd 2013, 5:37pm)

by ruchuck (May 29th 2013, 8:54am)

7 293

by mrfixit

(Jun 2nd 2013, 12:03am)

by Trabecca (Mar 13th 2013, 6:22pm)

7 374

by Trabecca

(Mar 18th 2013, 8:23am)

by Marvel (Jan 19th 2013, 6:54am)

7 736

by Marvel

(Jan 22nd 2013, 7:49pm)

Show

Statistics:

419 Threads - 1,565 Posts (average 0.35 Posts per Day)