You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by kenken55 (Aug 5th 2010, 10:55am)

2 857

by kenken1955

(Aug 28th 2010, 5:32am)

by aziz786 (Aug 9th 2010, 12:02pm)

2 407

by aziz786

(Aug 10th 2010, 12:49pm)

by Fisher (Aug 7th 2010, 5:43pm)

0 271

No reply

by frankmanic (Aug 5th 2010, 8:44am)

0 337

No reply

by kingtpt (Jul 17th 2010, 5:57pm)

5 446

by Fireguy97

(Jul 18th 2010, 11:35pm)

by RodQ (Jul 11th 2010, 12:54pm)

2 375

by hi.todd

(Jul 12th 2010, 12:49pm)

by schlaiss (Jul 1st 2010, 9:25pm)

1 315

by Wet_Boots

(Jul 2nd 2010, 8:59am)

by Kim (Jun 19th 2010, 6:45am)

1 354

by mrfixit

(Jun 19th 2010, 12:11pm)

by Gerrit Van de Haar (Jun 5th 2010, 2:40pm)

3 430

by HooKooDooKu

(Jun 9th 2010, 11:12am)

by mcsinkus (Jun 4th 2010, 4:35pm)

1 461

by mrfixit

(Jun 4th 2010, 7:49pm)

Show

Statistics:

496 Threads - 1,876 Posts (average 0.36 Posts per Day)