You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by Bob H (May 13th 2003, 12:54am)

17 697

by Bob H

(Jun 3rd 2003, 9:20am)

by WS-1 (May 9th 2010, 4:29pm)

28 8,478

by Romeo

(Jun 10th 2014, 3:57am)

by JT (Mar 9th 2014, 8:08pm)

1 175

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by GraemeDunkley (May 4th 2013, 10:50pm)

5 487

by electrifiedmale

(Jun 30th 2013, 7:14pm)

by lybrand (Aug 30th 2012, 3:54pm)

1 489

by Wet_Boots

(Aug 30th 2012, 4:50pm)

by nrwe (Jul 19th 2012, 1:57pm)

4 536

by mrfixit

(Jul 20th 2012, 3:06pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 2,004

by Wet_Boots

(Jun 20th 2012, 10:13am)

by hudr0004 (Sep 12th 2011, 10:16am)

4 562

by hudr0004

(Oct 24th 2011, 8:38am)

by hockeyist77 (Sep 1st 2011, 6:21pm)

4 852

by hockeyist77

(Sep 7th 2011, 3:47pm)

by fwoodall (Aug 28th 2005, 6:01pm)

2 910

by squints

(Jul 31st 2011, 2:16pm)

Show

Statistics:

436 Threads - 1,651 Posts (average 0.36 Posts per Day)