You are not logged in.

Controllers, Sensors, & Remotes

If you are having problems with your controllers, sensors or shut-off devices, or remote control kits for your sprinkler system, here is where you can ask questions. Replacement tips, adjustment suggestions, or troubleshooting.

Dear visitor, welcome to SPRINKLER TALK FORUM - You Got Questions, We've Got Answers. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Threads

by janeandjoseph (Jul 6th 2004, 11:05pm)

2 179

by janeandjoseph

(Jul 7th 2004, 8:03pm)

by jmm1804 (Jun 3rd 2004, 11:49am)

2 234

by jmm1804

(Jun 7th 2004, 12:53pm)

by Bob H (May 13th 2003, 12:54am)

17 657

by Bob H

(Jun 3rd 2003, 9:20am)

by mjtalmadge (Sep 11th 2011, 2:30pm)

4 2,167

by Jlinfield

(Jul 4th 2014, 11:42am)

by WS-1 (May 9th 2010, 4:29pm)

28 8,214

by Romeo

(Jun 10th 2014, 3:57am)

by JT (Mar 9th 2014, 8:08pm)

1 164

by Wet_Boots

(Mar 10th 2014, 5:56pm)

by lybrand (Aug 30th 2012, 3:54pm)

1 473

by Wet_Boots

(Aug 30th 2012, 4:50pm)

by nrwe (Jul 19th 2012, 1:57pm)

4 511

by mrfixit

(Jul 20th 2012, 3:06pm)

by Rsnic (Jun 17th 2012, 2:10pm)

6 1,930

by Wet_Boots

(Jun 20th 2012, 10:13am)

by Jonas_ (Mar 13th 2012, 9:40am)

10 1,812

by Wet_Boots

(Mar 16th 2012, 8:14am)

Show

Statistics:

435 Threads - 1,643 Posts (average 0.36 Posts per Day)